Bootstrap Input text properties


#1

The property ‘autocorrect’ when set to ‘off’ at design ti9me does not work and ‘autocapitalize’ when set to ‘on’ does not work. Setting ‘autocorrect’ to off is quite import. Is there a workaround?

Thanks, John


#2

It looks like we should set these attributes explicitly, instead of relying on the defaults. We’ll make a new build of AppStudio.


#3

Here is a test build. Let me know if it makes a difference:


#4

No, not working. It’s easy to test. Just start a new project and add an input control from Bootstrap. Turn all of the autos to off and F5. Type in garbage like lskdf and hit the space bar and the red wavy underline appears.

Thanks John


#5

What device/browser are you using for testing?


#6

Windows 10 Chrome 61

I also tried on Android with Chrome, same results.


#7

Wait, sorry, not true. Just tried on Android and I am not getting spell checking.


#8

When I go to Chrome’s Settings/Advanced/Languages etc and turn off spell checking the input control no long spell checks. This is probably the best I can expect when running a web app in Chrome on a PC. Still would be nice if it could be programatically turned off so the browser is not disabled for all sites.

Thanks, John


#9

I tried the test build. autocorrect=off works fine for Windows10/Edge, Android/Chrome (Sony Z1), Safari (IPad) but not for Windows10/Chrome.


#10

We just uploaded a new build. It has a new property for the Bootstrap controls called ‘spellcheck’. Try setting it to false.


#11

Yes! Now it works. Thank you.


#12

Thanks for the good news. We will include this in the next build.