Browser not launching


#1

I have installed to Win10 x64 machine.
Deploys to my server without any problem (albeit a bit slow) but cannot start in desktop browser.
The message in the status bar goes through the preparation but when it gets to Launching Browser - nothing happens.
I have checked the path to Chrome and it is the same as in a VM that I am using that does launch from AppStudio.
(C:\Program Files\Google\Chrome\Application)

I have uninstalled and re-installed NSB but still no joy.

Is there a setting somewhere that needs a tweak?


#2

Is there a URL I can try here?

Are you sure your server is configured properly?


#3

Apologies, perhaps I didn’t explain correctly:
I can deploy to my server without a problem.
If I try to run on the local desktop browser (F5) - that is when I get ‘Launching Browser’ but nothing happens.
It works fine on another machine so I’m guessing that there is a config error somewhere.


#4

What is in your deploy mode picker?


#5

As you show it - Start in Desktop Browser.


#6

I agree that there is something in your configuration which is causing a problem - but I’m not sure what to change.

In the About screen, you can look at the error log. Anything there?


#7

2017-12-04 15:22:46,388 - root - ERROR - An exception has occurred!

Traceback (most recent call last):
  File "appstudio\editor\design.py", line 715, in on_right_down
  File "appstudio\editor\design.py", line 633, in _context_menu
  File "site-packages\wx-3.0-msw\wx\_core.py", line 11144, in PopupMenu
PyAssertionError: C++ assertion "m_menuDepth > 0" failed at ..\..\src\msw\toplevel.cpp(1544) in wxTopLevelWindowMSW::DoSendMenuOpenCloseEvent(): No open menus?
2017-12-04 15:24:56,579 - root - ERROR - An exception has occurred!
Traceback (most recent call last):
  File "appstudio\editor\design.py", line 715, in on_right_down
  File "appstudio\editor\design.py", line 633, in _context_menu
  File "site-packages\wx-3.0-msw\wx\_core.py", line 11144, in PopupMenu
PyAssertionError: C++ assertion "m_menuDepth > 0" failed at ..\..\src\msw\toplevel.cpp(1544) in wxTopLevelWindowMSW::DoSendMenuOpenCloseEvent(): No open menus?
2017-12-04 16:33:42,226 - root - ERROR - An exception has occurred!
Traceback (most recent call last):
  File "MainFrame.py", line 1559, in OnToolClickStart
  File "MainFrame.py", line 1490, in OnMenuRunStartInDesktopBrowserMenu
  File "os.py", line 610, in spawnl
OSError: [Errno 22] Invalid argument

#8

appstudio-latest.log (1.2 KB)


#9

Let’s remove the registry entry:

  1. Start RegEdit (Windows Start button, enter regedit)
  2. Find HCU\Software\NSBasic\App Studio.
  3. Delete it.
  4. Restart AppStudio and enter your serial number again

#10

OK, I have done that. Regret same problem

Just hangs at this point.
Is there a particular location(path) that NSB expects Chrome to be.


#11

Does this happen with the AppStudio HelloWorld sample too?


#12

Yes - Basic Hello World hangs too.


#13

Here’s a test build which outputs some more debug info:


#14

Thank you. I have installed this version and deleted the previous ‘latest.log’.
Tried to launch in browser but it still hangs - and here is the new ‘latest log’.

appstudio-latest.log (308 Bytes)

2017-12-04 19:38:38,016 - root - ERROR - An exception has occurred!
Traceback (most recent call last):
File “MainFrame.py”, line 1559, in OnToolClickStart
File “MainFrame.py”, line 1490, in OnMenuRunStartInDesktopBrowserMenu
File “os.py”, line 610, in spawnl
OSError: [Errno 22] Invalid argument
2017-12-04 21:36:58,644 - root - ERROR - An exception has occurred!
Traceback (most recent call last):
File “MainFrame.py”, line 1490, in OnMenuRunStartInDesktopBrowserMenu
File “os.py”, line 610, in spawnl
OSError: [Errno 22] Invalid argument


#15

Just uploaded a build with more logging. Can you try once more? (same url)


#16

OK - This version completes and starts in Chrome. Both ‘Hello World’ and my own app get launched successfully.

Here is the latest log appstudio-latest.log (92.3 KB)

Hopefully, this helps you identify what is peculiar about my PC!
Is it OK to continue to use this version for now?


#17

Yes, continue using it. That it fixes the problem is quite unexpected.

Can you reinstall the release version and tell me if the problem comes back?


#18

Re-installed release v6.2.7.2 and problem returns.

Re-installed 2nd test version (without uninstalling) and problem remains.Get this error message and no launch.

An unexpected error has occurred. You may want to save your work and restart AppStudio. If this error persists, you may want to contact support with the details.

Traceback (most recent call last):
  File "MainFrame.py", line 1559, in OnToolClickStart
  File "MainFrame.py", line 1490, in OnMenuRunStartInDesktopBrowserMenu
  File "os.py", line 610, in spawnl
OSError: [Errno 22] Invalid argument

Uninstalled 2nd test version fully and Re-installed 2nd test version. Again get this error message and no launch.

Uninstalled again and deleted reg entries.
Re-installed,2nd test version - didn’t register and loaded ‘Hello World’. Failed again.
Bizarre


#19

Does the log show more info?


#20

appstudio-latest.log (252.4 KB)