Chrome not updating when "updating"


#1

Hi all

Having a lot of problem with chrome not updating a web app after I compile and upload it. It says “Updating…” when running the app and looks like it updates but everything is not updated. Safari on pc works fine. Android devices running chrome are getting the issue too.Is this something anyone else is experiencing? I would say it is not an AppStudio thing but definitely having more trouble since upgrading to v7. May be coincidence. If I clear chrome’s cache it updates ok but I lose all my localstorage then.

Cheers


#2

We don’t have other reports of this, nor did we make any changes in V7 in this area.

Check all your file names and paths - there could be a problem there. Also, look at the console output carefully for clues.


#3

This is what is in the console for an app that has been “updated” and not the latest version…

[Deprecation] Application Cache is deprecated in non-secure contexts, and will be restricted to secure contexts in M69, around September 2018. Please consider migrating your application to HTTPS, and eventually shifting over to Service Workers. See https://goo.gl/rStTGz for more details.
hfunc.js:4191 [Deprecation] Application Cache is deprecated in non-secure contexts, and will be restricted to secure contexts in M69, around September 2018. Please consider migrating your application to HTTPS, and eventually shifting over to Service Workers. See https://goo.gl/rStTGz for more details.
(anonymous) @ hfunc.js:4191
(index):1 Document was loaded from Application Cache with manifest http://www.farmmates.com/MixMateBeta/OfflineApp.appcache
(index):1 Application Cache Checking event
(index):1 Application Cache NoUpdate event
(index):1 This page includes a password or credit card input in a non-secure context. A warning has been added to the URL bar. For more information, see https://goo.gl/zmWq3m.

Anything there that might explain the issue?


#4

The Application Cache deprecation warning has been out for a while. We can’t do anything with it yet because Safari is still missing some critical functionality for Service Workers. There are also some concerns about the speed of Service Workers as well as older devices.

The other part of the warning deals with HTTPS. This might actually be the problem. The newest versions of Chrome no longer support loading from HTTP. Has your site been upgraded to HTTPS yet?


#5

No, my site is http. I can get https with dedicated IP for NZ$15/month. Is this the solution?


#6

You could also host your app on Volt, which is included with your AppStudio subscription.

You should be able to upgrade your site for free with a certificate from Let’s Encrypt:


#7

I am experiencing the exact same problem with version 70.0.3538 of chrome.

Safari works fine.

Ian.


#8

Not sure if I’ve fixed it but in Settings - Advanced settings-Content Setting-Javascript I added my website and now the app updates everytime, so far, and the plus is it happens instantly. I don’t see the ‘Updating…’ progress label any more


#9

I don’t know if this is the case for you but for me, I had to switch my web sites to ssl secure sites (https).
As of Sept. 28th Google Chrome does not permit appcache on unsecure sites.
No local storage either


#10

Yeah. I think that may have to be the answer for me. Thanks.