Font AWESOME without Internet Connection


#1

How do you use fontawesome without an internet connection? My app will not show a variety of ICONs when disconnected from the internet and won’t function properly.

I Get:
2use.fontawesome.com/530b34dcfd.js
"FAILED TO LOAD: NO INTERNET CONNECTION" (not the exact error, but close)

Can I add the Font Awesome to my Manifest? I am using PHONEGAP CLI.

Thanks!


#2

I never specifically used Fontawesome icons in the project.
It seems that it is used by the Bootstrap tools


#3

The files are in nsb/bs/fa. You could try adding that to the manifest.


#4

I don’t appear to have the ‘fa’ sub directory.
I am on Studio 6.1.2.0.


#5

In recent times in project folder neither a nsb/ folder . However you will find the /nsb/bs/fa folders within the folder of your app at your server, when you deploy (F6) the app .


#6

Thanks for your response. I am feeling a bit dense. I deployed the app locally and I still see no ‘fa’ sub-folder:
image


#7

Loaded the new version of studio. Found the fa sub folder. Added to manifest. same issue of icons for bootstrap not showing when off line:

I dont see any way around this. I tried to download the 530b34dcfd.js and point to it in manifest. I entered the Boostrap path, now that I have one.

Bootstrap tools function, but icons (especially Hamburger) do not appear when the app is started without connection to the internet. Bummer.


#8

I think George / Leader should explain this.

I agree that today it makes no sense looking for a nsb folder which is no more to be seen within the project folder.

Months or years ago a nsb folder was built within each project folder. There were always and still are warnings that one should not put own files into nsb folder.
So one can imagine they do not want you to do anything with the nsb folder.

In recent times my app folders do not contain (visible?) nsb folders any more. There is not yet any explanation about this change.
I had a problem comparable with yours. That’s when I noticed that the nsb folder is no more available or visible within the project folder.
One can find this folder nsb within the app’s folder following the path you indicated (Preferences menu) at your server when you already deployed with F6.

Bernd

PS: You can find NSB folder as well when you run your app (F5) and open the Chrome debugger (F12 within Chrome). See attached screenshot.


#9

Years ago, when you did “Run in local” browser, the runtime files were copied to the project directory and your app ran directly from there. An enhancement we made back then was to instead copy all the project files into a temp folder (along with nsb) and run it there as a web server would. It helped catch a lot of missing file messages which would only have been found later.


#10

I just ran a test that seemed to show nothing special needs to be done.

  1. New project.
  2. Add a button with a trash icon (which comes from FA)
  3. Create an APK and install it.
  4. Run the app - the icon shows.
  5. Put the phone in airplane mode.
  6. Run the app again - the icon shows.

#11

Thank you.
So the warning Do not put file in /nsb seems obsolete


#12

It’s still true. We just made it more difficult to do.


#13

So - you were able to get around the issue I was having when not connected to the internet? Is it because I am using a Bootstrap theme called ‘darkness’ in the project properties? Otherwise what are the exact modifications you made to the manifest?

Thanks!

Jimmy


#14

I made no changes to the manifest. Did you try repeating what I did?


#15

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.