Make native app with phonegap


#1

When trying to create app I get the following error

An error occurred while communicating with the PhoneGap server. 400 Client Error: Bad Request for url:
I am pasting the log file:

2019-02-04 15:27:02,151 - root - ERROR - An exception has occurred!
Traceback (most recent call last):
  File "MainFrame.py", line 1492, in OnMenuRunNativeAppMenu
  File "IDEController.py", line 65, in wrapper
  File "IDEController.py", line 2178, in PhoneGapDeploy
  File "IDEController.py", line 2112, in PostZip
  File "PhoneGap.py", line 58, in upload_app
  File "site-packages\requests\models.py", line 844, in raise_for_status
HTTPError: 400 Client Error: Bad Request for url: https://build.phonegap.com/api/v1/apps?access_token=ca0d44b9dcd5dbed6f0b4bbe79
2019-02-04 15:27:16,003 - root - ERROR - An exception has occurred!
Traceback (most recent call last):
  File "MainFrame.py", line 1509, in OnMenuRunNativeStatusMenu
  File "BuildStatus.py", line 90, in __init__
  File "BuildStatus.py", line 122, in StatusRefresh
  File "IDEController.py", line 65, in wrapper
  File "IDEController.py", line 2215, in PhoneGapStatus
  File "PhoneGap.py", line 34, in status
  File "site-packages\requests\models.py", line 844, in raise_for_status
HTTPError: 404 Client Error: Not Found for url: https://build.phonegap.com/api/v1/apps/3360184?access_token=ca0d44b9dcd5dbed6f0b4bbe79
2019-02-04 15:33:16,255 - root - ERROR - An exception has occurred!
Traceback (most recent call last):
  File "MainFrame.py", line 1492, in OnMenuRunNativeAppMenu
  File "IDEController.py", line 65, in wrapper
  File "IDEController.py", line 2178, in PhoneGapDeploy
  File "IDEController.py", line 2112, in PostZip
  File "PhoneGap.py", line 58, in upload_app
  File "site-packages\requests\models.py", line 844, in raise_for_status
HTTPError: 400 Client Error: Bad Request for url: https://build.phonegap.com/api/v1/apps?access_token=ca0d44b9dcd5dbed6f0b4bbe79
2019-02-04 15:39:24,482 - root - ERROR - An exception has occurred!
Traceback (most recent call last):
  File "MainFrame.py", line 1492, in OnMenuRunNativeAppMenu
  File "IDEController.py", line 65, in wrapper
  File "IDEController.py", line 2178, in PhoneGapDeploy
  File "IDEController.py", line 2112, in PostZip
  File "PhoneGap.py", line 58, in upload_app
  File "site-packages\requests\models.py", line 844, in raise_for_status
HTTPError: 400 Client Error: Bad Request for url: https://build.phonegap.com/api/v1/apps?access_token=ca0d44b9dcd5dbed6f0b4bbe79

Last time I created/updated the app it worked fine (there was about 3 NSB studio updates in between.
My current version is: 7.2.1.1
Registered to Zack Snyders
Monthly subscription


#2

Try deleting the PhoneGap ID in your project’s properties and uploading again.


#3

I deleted the BuildID, assuming thats what you meant.
Now I’m getting:
No resource identifier found for attribute ‘appComponentFactory’ in package ‘android’


#4

It’s actually more likely that this is due to a change in PhoneGap than AppStudio.

Are you building using your own PhoneGap Build account? If so, you can log in there and see their log file.


#5

No, I am using the default from the Appstudio menu. What else can I try?

Rgs

Zack


#6

What’s the name of your app? I’ll look it up.


#7

Responseman

I deleted id again and tried again.
Now get a different error

Private app limit reached


#8

Looks like PG have limited our free demo account again. We’ll get in touch so they can fix it.

In the meantime, you can set up our own free account. Here’s how to link it to AppStudio:
https://wiki.nsbasic.com/PhoneGap_AuthToken


#9

I have obtained token from Adobe Phonegap.
I still get the same error.
No resource identifier found for attribute ‘appComponentFactory’ in package ‘android’
Maybe I’m not specifying the parameters in Phonegap correctly?
However, even with the error, the app has built in Phonegap.
In Phonegap I get the following error:

Error - This version of PhoneGap is too old for one your plugins. Please update or add the android-targetSdkVersion preference to be at least 27

Where/how do I correct this?
Thanks


#10

Hi, some feedback.
I have done 2 things:

  1. I included
<platform name="android">
    <preference name="android-targetSdkVersion" value="28" />
</platform>

in the config.xml
2. Took out a Phonegap subscription
Bottom line, the problem went away after the subscription and another instance of my app with a different id now appears in Phonegap that compiles çlean’and can download.
The previous version of the app with other id is still there and still gives an error. Weird.
ANyway, thanks for the support.
rgs
Zack


#11
preference name="android-targetSdkVersion" value="28"

#12

Thanks for posting the solution.

A reminder here that PhoneGap is not our product. We don’t claim to be experts at it, not do we provide free support for it. We help where we can.
https://www.nsbasic.com/app/support.php/


#13

I do understand and really appreciate your help.

There are so many variables that can go wrong.

Just glad that we got to a solution.

Kind regards

Zack


closed #14

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.