Phonegap update version?


#1

I just tried to build the sample phonegapAPI and make the native app with phonegap.
but the error is coming always cannot read property undifend line…

is the version changed? must i change something in the project properties and global code?
config xml?

is there not a youtube sample movie or white board where it is corrected explained how your cross reference worked? or how you can add a new plugin from a new project?

i worked always in the CE version,


#2

Can you give the exact error and when it happens?


#3

the error is
cordova/plugin/barcodescanner not found.


#4

And when do you see this message?


#5

I see it when it starts, locally on the webbrowser it can not work it must deployed on the device.
so i made an apk and put on the the device
in the device i get " cannot read property undifend line 6."
It is just a sample who is delivered with the latest version 6.7.2


#6

I just tried it here. I also get an error message - but not quite the same one.

These things happen when PhoneGap updates its libraries. Let me see if I can find the solution…


#7

In Project Properties, open PhoneGap config.xml. Modify the barcodescanner (around line 105) to read:

<plugin name="phonegap-plugin-barcodescanner" source="npm" spec="6.0.8" />

That will make sure the proper version of the control gets loaded.


#8

Thx it worked now, maybe a tip to update the sample files. but in fact they can change it possible every 2 weeks :frowning:


#9

Thanks for the good news. The sample is updated in the next build.


#10

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.