Problem Example Geolocation error Permissions Android Not answered


#1

Hi George,

I saw this same topic, without answer…

I I had not noticed, because I use iphone, but for a few months I started receiving complaints from users who use android saying the app does not read the coordinates.
That happened a month or two ago.
I changed it to cli 7.0.1, 8.0.0
I put different versions

' ''

Finally I decided to start from scratch and take the geolocation example from appstudio

If you do not put the plugin nor the version of the phonegap cli, it displays a message of lack of access to geolocation.

If you put the plugin, it shows the location icon but the error, timeout expired.

iOS works ok, but android is unviable.

I tried with App studio 6.x and 7.x, using the geolocation example.

Try compiling and using an android, it’s impossible.

I searched a lot on google and did not find the answer.

I accept suggestions

Regards
Vagner


#2

Is this under PhoneGap?


#3

Yes in Phonegap i tried 6.5.0 7.1.0 8.0.0


#4

OK, Issue has been moved to PhoneGap.

Have you connected the Chrome Remote Debugger to see if there are any error messages?


#5

George, i tried in Debugging, same problem, see it below


#6

OK, I will set up a test here. It may take a couple of days - we are backed up here. What version of Android are you using?


#7

I´m testing in Android 5, 6 and 7
Couple days is cool,
I’m suffering already a week ago, looking for a solution on google …


#8

If you’re running under PhoneGap, you need to use the plugin. Do you have these lines in your configxml?

<plugin name="cordova-plugin-geolocation" source="npm" />
<edit-config target="NSLocationWhenInUseUsageDescription" file="*-Info.plist" mode="merge">
    <string>need location access to find things nearby</string>
</edit-config>

#9

I am using this
NSLocationWhenInUseUsageDescription

but works only in iOS, i will try again


#10

Follow config.xml lines

need location access to find things nearby

with cli 6.5.0 , have no permission to geolocation
with cli 7.1.0 timeout expired.
Let me attach the projectGeolocation.zip (48.5 KB)