Where do you enter the Google Map API Key?


#1

I keep getting the following error:
Google Maps API warning: NoApiKeys

Are there any steps on how to do it?

Thanks


GoogleMap Control
#2

This may be helpful GoogleMap Control

The control needs to be updated.


#3

Thanks. I put it in the Extraheader and it worked.


#4

That’s awesome and good to know.


#5

arrrg
I was mistaken. It worked when Started on Desktop Browser
When deploying to ftp i get:
maps.googleapis.com/maps/api/js?v=3.exp&callback=GoogleMap1.refresh:38 Google Maps API error: MissingKeyMapError https://developers.google.com/maps/documentation/javascript/error-messages#missing-key-map-error

MissingKeyMapError Error
The script element that loads the API is missing the required authentication parameter. If you are using the standard Maps JavaScript API, you must use a key parameter with a valid API key. If you are a Premium Plan customer, you must use either a client parameter with your client ID or a key parameter with a valid API key.

See the guide to API keys and client IDs.


#6

This is fixed in the next build of AppStudio. It should be out this weekend.

George


#7

Thanks.
Since you are making changes. The following throws an error. The translation misses the colon
marker = GoogleMap1.setMarker({position : point})
gets translated to
marker = GoogleMap1.setMarker({
position point
});
Instead of
marker = GoogleMap1.setMarker({
position: point
});


#8

I can’t reproduce this one. Can you make this happen in a small project?


#9

It happens to me in BASIC\3. Controls\Finance and Social Media\GoogleMaps.nsx
Si how the line is underscored red. If I select View Javascript it shows this:

and when the mousepointer is on top of the line, this appears:


#10

Still no luck reproducing this here. What version of AppStudio are you using?

George Henne
NS BASIC Corporation
http://www.nsbasic.com


#11

I have version 6.2.3.1 Developer Edition

I tried it now after a fresh laptop start (Windows 10) and it works fine
now and even the View Javascript now shows the colon OK so it may have
been that all it needed was a reboot.

Sorry about that.

Mario


#12

@mariolavignasse thanks for checking back and letting the community know.


#13

Added in 6.2.4. There’s a new property in the GoogleMap control for this.


#14

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.