AppStudio not run App in browser


#1

Hi,

After cleaning google Chrome cookies and caches, AppStudio not runs App in the browser and does not generate apk.

Other Apps are running normally.

I use Windows 10.

Any idea?


#2

I have asked you this before. May I ask you once again?

Please provide sufficient information in your question so it can be answered. You’ve given us virtually nothing to work with here.

  • What exactly happens when you try to run your app in the browser?

  • Do any error messages show up in the Chrome Debugger?

  • What exactly happen when you try to create an apk?

Asking good questions will get you working much more quickly.


#3

Young man,

I understand your questioning, but the information I have is the one that follows in the images.
AppStudio does not open the browser and does not show any error messages, it simply does nothing! However this happens only with this App, other apps I can run in the browser and debug it.

I have already uninstalled and reinstalled AppStudio and nothing has changed

The items circled in red do not work, I click on them and nothing happens, no error message is displayed.

Look:

Another App Generating Apk Usually

Another App run in browser


#4

Can you zip your entire project folder up and send it to me? I’d like to see if this happens here.


#5

Thank you for sending me your project. It includes a database called iCat.db, which it needs to convert to JSON as part of the deploy.

Unfortunately, there is an error in converting the database - the data cannot be serialized into JSON. The error shows up in the log, but not on the screen.

We’ve improved AppStudio so that a nice message appears in this case. You’ll still need to figure out what is wrong with the database.


#6

I believe the error was generated after adding the [img] BLOB type field in the table to store the images

Look:

I removed the img field and it worked again, but we returned to the initial problem of storing images in SQLite or in a directory on the device to display in the ListView.

As we saw there is problem in writing image in SQLite database.

What is the solution?


#7

Yes, that would cause the problem.

Convert the image to Base64, then save it as a string.


#8

Yes man, that’s what I’m talking about.
Simple questions and great answers to simple solutions.
I will be publishing soon all the solutions we had, let’s make AppStudio the best tool for development.
Whether for beginners or experts!
I am very satisfied with AppStudio, but we can improve and we will improve its functionality through the exchange of information.

My App is working.

Thank you George.