MsgBox problem in iPhone 5


#1

Same app:
The MsgBox works incorrectly on the iPhone 5 - it only seems to do this on one form in the app.

iPhone 6s iOS 11.2.6

iPhone 5 iOS 10.3.3


#2

If you perform this same message on another form of your app, what happens?


#3

I tried the same message on another form and it displayed correctly.


#4

I don’t know if it’s relevant, but this message appears within a _onchange() function for a Select control. I tried putting another message with a _onchange() function for a different Select control on a different form, and I had the same problem (again only on the iPhone 5 - not the iPhone 6)


#5

I created a new app and ran it on an iPhone 5 SE. It worked properly there.

If it only happens on that form and that phone, I wonder if there is something else on that form which might be causing this.


#6

I don’t know if you saw my last post. It seems whenever I call Msgbox from within an _onchange() function for a Select control it happens. I had another form with an _onchange() for a Select control and when I put a Msgbox in there it also happened (only on the iPhone 5). I don’t know if you tried it with those circumstances.


#7

I did - the main difference was an iPhone 5SE (yours is a 5, I believe). Give this a try:

https://project1-wants-oddly.volt.live


#8

I haven’t been able to find anything except that it only happens whenever I call Msgbox from within an _onchange() function for a Select control (on iPhone 5 only). Not to worry, I’ve built my own modal form to replace Msgbox in those instances and it works normally. I didn’t get a chance to run your https://project1-wants-oddly.volt.live - it had disappeared before I noticed your reply.


#9

Try it again now…