Problem with latest version


#1

Hi guys,

I have upgraded to ver 6.3.1.0

Started and project ( attached).

I set the form to relative.

Added an image and set to all to auto.

Then copied and pasted the image a few times.

The images stay on top of each other even if I change top value.

Unless I’m being dumb here ( it was a late night )

Cheers

Steve Warby


#2

That sounds about right, actually. In relative positioning, controls default position to the top right. Read more about positioning here:

http://blog.nsbasic.com/2016/11/appstudio-6-positioning-controls/


#3

Relative.

When a control is added the Design Screen, it will go to the left side of the form, positioned under the control before it. Dragging the control to a new position will have no effect: it will snap back to the same place. Setting values for top, left, width and height will affect the position.

The images are on top of each other.

Am I missing something here.


#4

What exactly are you setting to auto?

If I try this here without changing anything on the Images, they seem to position properly.


#5

All the bounds setting are auto.

I’m on a Mac ( maybe the issue)

testImagesNsbasic.zip (1.2 MB)


#6

I used a Mac here too. Here is what I did to try to reproduce your problem:

  1. New Project
  2. Set positioning on the form to relative.
  3. Drag and drop a BS Image. I don’t change any properties.
  4. Select it and copy.
  5. Paste
  6. Paste

I get what I expected: 3 images vertically stacked:


#7

What do you get if you open my project ?


#8

I’m not seeing the attachment. Can you send it again?


#9

Just tested again on 6.3.1.0 and seems okay.