Programming for older android phone


#1

I have AppStudio 5.2.1.3
I use PhoneGap Build to build my apps
I have a Samsung GT-S5360L with Android 2.3.5 on it.
When I try to install an app made with AppStudio 5.2.1.3, I get a “Permanent Failure” message,
or it won’t install at all.
Older apps that I made seem install all right.
Is there a setting some where for older Android OS’s?
Is there a way for me to program for older Android phones?
Thanks.


#2

Moved topic to PhoneGap.


#3

You’ll need to look at the PhoneGap docs to see if there are restrictions. PhoneGap steadily makes changes to its service. We don’t have specific knowledge of this.

  • Does a simple HelloWorld app work?
  • In Project Properties, there is a PhoneGap Version which you can use to tell PhoneGap to use an older version of its software.

#4

The phone was very old. It was unlocked and only about 3 inches in height, which is why I wanted to use it.
Not worth the effort to try and fix the code any more. Couldn’t even get the App Inventor companion to download to it. Finished.
I decided to buy a 3 inch phone with a more current Android operating system on it. $35 worth to try it out.
Thanks for your help.


#5

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.